新建：

① 变量的导入：程序是最新版的，与以前的变量导入不一样。一个空的项目，在没有变量文件(variant.dat)或变量文件无变量的情况下，是不能打开IDE.exe程序的。首先要用ImportVariant.exe工具将变量导入。（如果没有Excel变量文件，则用别的变量代入导入，进入程序后再删除）

② 对旧版的Excel变量文件，需要升级到最新的版本，否则将导入不了变量。

③ 对于需要使用web浏览的项目，每个变量的属性<是否保存数值>和<是否实时采集>都是要勾上的。

④ 对于定位漏水的变量，在变量<漏水报警>的属性面上的<选择变量> [image] 必须选择定位漏水变量<漏水位置>

⑤ 告警变量，状态报警只需勾上<是否远程报警>即可，数据报警变量，则还需勾上<报警内容是否显示当前值>

⑥ 在新建变量时，不要忘了给数值变量标上单位，如电压单位 V。

⑦ 告警变量，一般告警变量都有二种状态值：正常值和异常值。我们除了在变量属性页面上设置<设置状态>进行二种状态值的设置，同时还要在属性面的<正常值>时行设置。

⑧ 多个Excel变量文件的导入，有可能会出现错误。一般出错错误都是因为变量的<位信息>出现相同，导致导入错误。此时只需将<位信息>的id重新生成即可。

⑨ 在新建的项目当中，如果发现某个图元的在<参数设定>页面上的<填充><类型>里没有下拉值出现，是因为在项目的IDE目录下的Bitmap文件夹里的一些位图被删除了，只需重新添加即可。

⑩ 变量中的<开的描述>和<关的描述>二个字段，分别是 0 和 1的状态值。也就是说，我们的程序<开的描述>是与 0 对应的，<关的描述>是与1对应的。如果遇上1为开的话，那么<关的描述>就写“开”，同理0。

⑾ 串口通信状态：0为通信正常，1为通信断开。注：是一个设备一个串口通信状态。

整理：

① 对于已完成的项目，一般都要整理，把变量导出成Excel格式，以备下次使用。在导出变量时，应该注意更改Excel的sheet片的名称，要改为：变量dat文件。否则将不能导入变量

② 整理旧版变量时，除了要升级成为新版的以外，还需要注意变量的一些属性值。因为在导出为Excel文件时，这些值将无效。所以，要对照旧版变量的数据库进行重新设置。这些变量一般有：<转换系数><最大转换比例><最小转换比例><上限><下限>

③ 宏格常开：1 常闭：0。

常开：NO | 常闭：NC
灯亮 | 灯灭
状态：1 | 状态：0
一般接法：灯亮为正常，即状态为1
接D8H时，灯灭为正常，即状态为0

（图元 框内色：245，249，255（240，252，255） 边框色：204，209，240 背景低色：232，240，249）

④ 短信猫的 at 指令：

指令形式 | 用途 | 正常返回值 | 错误返回值 | 异常值 | 说明
At | 确认接通 | OK | |||(波特率Error) |  |
At+csq | 信号质量 | 15~36 | 除正常值外的 |  |
At+cmgs = 手机号 | 测试通信 |  |  |  |
At+cmgs = 13590478415
>hello (正常，按ctl+z发送) 返回 sendOk
>error（错误）

RS485和RS232设备线的接法：

485 232

设备通信串口报警设置：正常状态是0，报警为 1；

状态值的开关描述：

<开的描述>对应的状态值是正常状态的值;

<关的描述>对应的状态值是开的反值，也就是与正常状态相反的值；

分辨率：

电脑分辨率，17寸正屏的，用980×650的监控图（侧边栏收起）

19寸宽屏的，用

问题：

ImportVariant.exe工具：在office 2003的基础上，再装office 2010，会出现导出失败，提示<找不到可安装的ISAM>

答：只需注册 Excel ISAM即可

在“运行”对话框中输入回车即可:Regsvr32 c:\WINDOWS\system32\msexcl40.dll

预留2_Bool 为 是否触发远程报警

预留1_Bool 为 是否显示当前值

VS2003无法启动调试 没有正确安装调试器错误解决方案

当你遇到“试图运行项目时出错:无法启动调试 没有正确安装调试器。请运行安装程序安装或修复调试器”，请尝试下面的操作可以解决你的问题：

1、请确定你的操作系统是否运行在debug模式下，此时VS.NET将不能调试。

2、确定你的项目已经启动了“非托管代码”调试选项。

3、尝试重新安装VS.NET中的修复选项。

4、在命令行中尝试重新注册mscordbi.dll(regsvr32 mscordbi.dll)文件，该文件位于（C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322请找到你本机的这个对应的目录）。

5、在命令行中尝试重新注册oleaut32.dll（regsvr32 oleaut32.dll）

6、运行C:\Program Files\Common Files\Microsoft Shared\VS7Debug下面的mdm.exe /regserver

具体如下：
1，在运行处输入cmd
2，然后输入命令：cd C:\Program Files\Common Files\Microsoft Shared\VS7Debug
3, 再输入命令：mdm.exe /regserver
4,再到服务里查看是否有 Machine Debug Manager服务，此服务如果停止则启动即可。

监控图单位：

单位的应用字体：

描述的应用字体：

数据的应用字体：

一般在UPS中，我们最好把频率或负载用蓝色的数据来显示，做到突出显示重要数据