na-1.htm

欢迎使用优秀下载软件
网络蚂蚁 Version 1.25

友情制作——吉林侯家驹

概述

随着因特网用户的迅猛增长，使不断发展的因特网仍然不堪重负。而且当前的软件也变得越来越大，在下载时人们经常遇到网路阻塞，甚至使下载的文件不完全，而成为垃圾。这对时间和金钱都是惊人的浪费。幸而因特网的创建者把“断点续传”（RESUME）引入了HTTP和 FTP协议为基础的RFC中，使这一问题得以解决。 在第一代下载软件GetRight之后出现了多线程的把文件分成几个部分同时下载的第二代软件。NetAnts 就是第二代下载软件，它是从因特网下载文件的很好用的下载工具。 NetAnts的特点见下面“特点”部分。

特点

NetAnts是特点丰富的软件。它有下列主要特点，并且在今后的版本中会增加更多的内容。
  • 是具有断点续传（RESUME）功能的HTTP/FTP多线程下载软件；
  • 支持HTTP/FTP代理服务器；
  • 可灵活的成批处理下载任务来下载多个文件；
  • 把要下载的文件从浏览器上拖到拖曳窗口中即可下载；
  • 下载文件可自动分类存放；
  • 具有多种自动和定时功能；
  • 可与多数浏览器整合；
  • 可检测远程服务器是否支持断点续传；
  • 可监测数据传送速度，自动或手动控制数据流量；
  • 可用病毒扫描程序来扫描下载文件；
  • 添加任务、完成任务和中断时，可用声音提醒；
  • 可用winpopup在局域网内提示信息；
  • 下载完成或遇到错误而终止下载时弹出信息框。

在这次发布的版本中有什么新特点

  • 修改了一些错误；

各版本的修订历史

注：各版本修订的详细信息请查看文件History.txt。

2001年6月 1.24版

  • 支持浏览器NetCaptor的点击捕获；
  • 下载完毕后自动运行；
  • 改进了“添加多个任务时”选择文件的方法；

2000年5月 1.2版

  • 可以选择改变窗口风格；
  • 更好的多语言支持；
  • 可以修复损坏的下载的zip文件；
  • 独立控制每个蚂蚁的行为，包括启动和停止某个蚂蚁；
  • 可同时修改多个任务的属性；
  • 主窗口界面显示的项目可选择、改变；
  • 可记忆上一次下载文件的存放目录；
  • 下载任务数据库自动备份；
  • 可在删除任务的同时也删除已下载的文件；
  • 所有任务可使用缺省代理服务器配置；
  • 自动获取拨号网络的口令；
  • 用任务优先权为“0”来控制“不下载”。

2000年4月 1.1版

  • 新增和改善了用户界面 ；
  • 改进了存盘文件更名的输入方法；
  • 对FTP ASCII模式更好的支持；
  • 双击任务列表中已下载完的任务项可以运行该文件；
  • 根据从服务器获得的信息调整本地文件名 ；
  • 自适应的拖曳窗口；
  • 支持SOCKS4和SOCKS5代理服务器；
  • 任务完成或中止时，弹出通知消息窗口。多个通知消息将显示在同一个窗口中；
  • 下载过程中，任务状况窗口中的信息将自动下滚。
  • 在添加任务对话框中为添加多个任务可使用掩码。

以前的各版本

2000年2月 1.0正试版发布
1999年10月 1.0 beta 2.75
1999年8月 1.0 beta 2.70
1999年8月 1.0 beta 2.67
1999年8月 1.0 beta 2.65
1999年7月 1.0 beta 2.60
1999年4月 1.0 beta 2.55
1999年2月 1.0 beta 2.51
1999年2月 1.0 beta 2.50
1998年10月 1.0 beta 2.41
1998年9月 1.0 beta 2.40
1998年8月 1.0 beta 2.30
1998年8月 1.0 beta 2.20
1998年7月 1.0 beta 2.10
1998年7月 1.0 beta 2.00
1998年6月 1.0 beta 1.01
1998年6月 1.0 beta 1.00最初发布


 安装与卸载

安装

第一步--下载NetAnts

NetAnts通过互联网分发。你可从主页www.netants.com下载最新版本的NetAnts，或在国内主要网站下载 NetAnts的最新版本。
NetAnts的安装包是单一的可执行的 EXE文件文件。

第二步--安装NetAnts

运行下载的安装文件。如果下载的是zip文件，首先用 winzip解压 (可点击这里下载 Winzip)。运行NetAnts的 EXE文件后，按照安装向导提示的安装过程进行安装。你首先要看软件许可协议，同意协议后，选择安装位置（推荐的缺省位置为C:\Program files\netants）。在文件复制后，可选在桌面上建立NetAnts的快捷方式以简化操作，并可选择是否查看Readme文件。
安装结束时，如果您的浏览器已运行的话，将提示重新启动浏览器。这将保证NetAnts与浏览器正确的整合。至此，安装过程即顺利的完成。
如果安装时遇到问题，应当重新下载安装文件。也可查阅“问与答”部分，或者与作者联络。

卸载NetAnts

可从windows“开始→程序→NetAnts→Uninstall NetAnts”把 NetAnts从系统中卸除。
也可从控制面板的“添加/删除程序”中卸载NetAnts。


启动netants8

运行环境与启动

运行环境:

    windows 9x/2000/NT
    Microsoft 32 位 TCP/IP 堆栈

启动NetAnts:

  • 如果你从浏览器网页上找到要下载的文件，右击URL并在弹出的菜单中选择“Download by NetAnts”。NetAnts 将自动开始运行，并且出现“添加任务”对话框。在对任务设置全部完成，并点击“确定”按钮后，即开始下载。
  • 从浏览器IE的“工具”菜单项点击“NetAnts”也可使NetAnts启动。
  • 从Windows“开始→程序→NetAnts”也可启动NetAnts。


na_4.htm

用户界面

NetAnts用户界面主要有以下部分(点击这里在屏幕上将显示界面)：

    主菜单——主窗口最上面是主菜单。菜单项的功能解释在这里。

    工具条——工具条在主菜单下面，它集中了大部分NetAnts的功能。工具条上按钮分成三组：任务控制功能、自动/定时功能、工具/选项功能。全部按钮的解释在这里.

    虚拟文件夹——主窗口左边是树形结构的“虚拟文件夹”。用它来查看下载任务项。

    任务列表——主窗口的右上方部分。所有任务在这里根据其状态分 类列表。

    任务状况窗口——主窗口右下部分是下载任务的细节描述部分。在 任务列表中先选中某下载任务，该任务的详细信息即列在这里。点击这里可查看更详细的内容。

  • 除广告窗口外所有的窗口都可以选择是否显示:在主菜单中选择“窗口显示”，用户可以在子菜单中选择是否显示每个功能窗口。


用户界面netants4-1

Close


na_4-2.htm

 任务状况窗口

主窗口右下部分是下载任务的细节描述部分。在任务列表中先选中某下载任务，该任务的详细信息即列在这里。它分四个部分：

  • 区块——显示蚂蚁下载的进度。在下载过程中，用户可以独立控制每个蚂蚁的行为。在任务状况窗口左侧的每个蚂蚁图标上按鼠标右键，会显示菜单，包括启动和停止该蚂蚁；
  • 日志——显示NetAnts与服务器连接、数据传输等信息。日志窗口自动滚屏：下载过程中，日志窗口中的信息将自动下滚，保证用户能及时看到最后的信息；

    • 下载过程中可对每个蚂蚁进行控制：在日志窗口的蚂蚁图标上点右键，弹出菜单。可选择该蚂蚁的停止、开始、重新开始来控制该蚂蚁。

  • 信息——显示下载的信息，包括：下载目标、存盘目录及文件名、文件日期、下载日期、文件大小、已接收字节数、剩余字节数、远程服务器是否支持断点续传、已用时间、剩余时间、总共下载时间，当前传输速率(BPS)，平均传输速率以及连接已发生的错误数。
  • 链接——显示处理网页URL的有关信息。


na_5.htm

 主菜单

主菜单控制NetAnts全部的功能。在这里将解释菜单项的使用。

“文件”菜单项：

  • 导入URL列表：从TXT文件导入URL，要求TXT文件中的每行是一个下载任务的URL。
  • 成批添加新任务：根据某些规律生成系列URL。
  • 处理网页文件：解析给出的HTML文件，把其中全部下载的URL挑选出来。
  • 导入未下载完的文件：导入浏览器未下载完的文件。
  • 查看下载纪录：可打开纪录文件查看所有进行过的下载任务纪录。
  • 清除下载纪录：可清除下载任务纪录内容。

“编辑”菜单项：

  • 选定全部下载任务：可选定显示在任务列表中的全部任务。
  • 反选：根据已经选中任务进行反向选择。
  • “添加／编辑／删除”：可在任务列表中控制单个任务。
  • 从任务列表中删除全部已完成的下载任务项（ 可选择是否删除已下载的文件）。
  • 对未下载完的任务可以在任务窗口中选择多个任务，然后选编辑功能，就可以同时对多个任务的属性进行部分修改。可修改的内容有蚂蚁数目、优先级、出错处理、超时、代理服务器、HTTP协议的提交者和用户代理以及FTP协议的ASCII模式等。

“下载”菜单项：

  • 开始／停止：开始或停止选定的任务；
  • 开始／停止全部下载任务：开始或停止全部的下载任务；
  • 再次下载：再次下载所选定的过去已下载完成的任务；
  • 检查文件是否已更新：检查文件是否已被更新，如果选用此功能则可下载更新的文件；
  • 定时下载/定时挂断：使全部待下载的任务设置定时下载或定时挂断。

“窗口显示”菜单项：

  • 可选定显示/不显示主窗口中的工具条、状态栏、柱状图、虚拟文件夹和拖放窗口；
  • 可选定显示/不显示任务状况窗口中的区块、日志、信息、链接四个部分的任意部分；
  • 用定制选用工具条菜单项，可选定显示/不显示工具条的内容并可调整各按钮的先后次序；
    •
  • 用定制选用任务栏菜单项，可选定显示/不显示任务栏的内容并可调整各栏的宽度以及它们的先后次序；
  • 用language菜单项，可灵活的选定使用的语种。

“选项”菜单项：

  • 设置：弹出选项设置对话窗口，以设置NetAnts。
  • 与浏览器整合：在浏览器中点击一定类型的URL来获取下载的任务。
  • 剪贴板监视：对一定类型的URL进行剪贴板监视。
  • 自动拨号、自动挂断、自动关机等项可使NetAnts进入定时自动工作状态
  • 速度限制模式：控制用于NetAnts下载文件的带宽。详细内容可查阅数据流的控制部分。

“工具”菜单项：

  • NetAnts拨号：启动NetAnts时开始拨号上网。
  • NetAnts书签：把常用任务保存到书签。

“帮助”菜单——在这里有帮助信息和联络信息。


na_5.htm

 右击弹出菜单

在主窗口的任务窗口中右击鼠标将弹出菜单，其菜单项的功能为：

“文件”菜单项：

  • 开始／停止：开始或停止选定的任务；
  • 开始／停止全部下载任务：开始或停止全部的下载任务；
  • 再次下载：无条件地再次下载所选定的文件；
  • 检查文件是否已更新：检查文件是否已被更新，如果选用此功能则可下载更新后的文件；
  • 添加／编辑／删除：可在任务列表中控制单个任务；
  • 复制URL：把任务的URL复制到剪贴版；
  • 加入到书签：把任务的URL加入到书签；
  • 导出URL列表：把URL到出并建立.lst文件；
  • 运行：运行已下载的文件（在设定的文件存放目录中）；
  • 浏览：浏览已下载的文件（在设定的文件存放目录中）；
  • 外壳：执行资源管理器里面的所有关联操作；
  • 修理损坏的Zip文件：下载完毕后，文件可能发生损坏而无法打开。这时，可以利用此菜单项的功能修复损坏zip文件，网络蚂蚁将检查这个zip文件的CRC校验并标出损坏区域。检查结束后，再重新启动任务，让网络蚂蚁重新下载损坏区域即可。（文件必须在设定的文件存放目录中）；
  • 设置优先级：可设定任务的优先级，一般为1—5级，若设为0级即为“不下载该任务”。


弹出菜单

Close


 拖曳窗口的使用
  • 用工具条按钮 [image] 来显示拖曳窗口。
  • 双击拖曳窗口可显示主窗口界面。
  • 右击拖曳窗口可显示“弹出菜单”。

Close


na_6.htm

 工具条

---- 从文本文件导入 URL | ---- 产生系列URL
---- 从本机HTML文件获取 URL | ---- 进行选定任务的下载
---- 停止选定任务的下载 | ---- 添加新任务
---- 编辑选定的任务 | ---- 删除选定的任务
---- 由NetAnts来控制运行拨号等 | ---- 需要时自动拨号上网
---- 全部任务完成后挂起 | ---- 全部任务完成后关机
---- 定时下载 | ---- 定时挂起
---- 数据流控制 | ---- 显示／隐藏拖曳窗口
---- 设置选项 | ---- 退出NetAnts


na_7.htm

选项设置

“选项”对话框有11个标签页。每个标签页的描述如下：

连接

在“连接”标签页上，可设定:
  • 出错处理：网络连接出现错误时重试次数以及两次重试之间的间隔时间。
  • 超时：处理连接出现的问题或数据接收问题前，等待服务器应答的时间（秒）。
  • 限制：最大下载任务数，范围为1—10。
  • 带宽：速度限制和调整值，详见数据流控制部分。

任务的默认设置

在“任务的默认设置”标签页上，可设定：
  • 下载文件存放目录：预先未设定下载类型的文件，下载时存放的目录位置。
  • 杂项：设置每个下载任务用的蚂蚁数目，以及添加的任务是否立即开始下载。

自动

在“自动”标签页上，可设定:
  • 与浏览器点击整合：点击已设定类别的URL来获取。
  • 剪贴板监视：对一定类型的URL监视剪贴板。
  • 病毒扫描：应用病毒扫描程序自动扫描下载的文件。
  • 自动运行：下载完毕后自动运行本地文件。

代理服务器

在“代理服务器”标签页上，可设定:
  • 可添加、删除、编辑代理服务器的设置；
  • 可选用默认的http代理服务器，或默认的FTP代理服务器；

    • 关于代理服务器的详细内容，点击这里。

    提示：如果在防火墙里面，设定／不设定PASV模式将影响你的连接性能。

拨号

在“拨号”标签页上，可设定：

    拨号上网：选择计算机上网使用的“连接”。NetAnts拨号是使用windows 的 DUN工具。可以在windows控制面板的“网络”选项中设置连接，NetAnts能与它完美的配合 。
    自动获取拨号网络的口令:配置拨号时，可以不填写用户名和口令，网络蚂蚁将从系统拨号网络中获取上一次的用户名称和口令。

定时

在“定时”标签页上，可设定:

  • 定时下载：在设定的时间开始下载。
  • 定时挂断：在设定的时间挂断。

    • 也可用工具条上的“使用／不使用定时”来选定。但是，时间只能在此标签页上设定。

存贮

在“存贮”标签页上，可设定：

    可按下载文件的扩展名来分类存贮在不同的目录中；可添加、删除、编辑分类与存贮目录。如果文件扩展名不能和任何定义的类型相匹配，它将存放在默认目录下（参见“任务默认设置”部分）。

安全

在“安全性”标签页上，可设定：
    可添加、删除、编辑按URL的类型设置的用户名和口令。

显示

在“显示”标签页上，可设定：

  • 柱状图颜色：设置直方图的颜色。
  • 柱状图比例：设置直方图的比例。
  • 启动时NetAnts的显示模式：启动时NetAnts显示为主窗口或在系统任务栏上显示NetAnts的图标。
  • 通过窗口形式下拉框可以选择不同的窗口背景风格。NetAnts目录下的Skin子目录中，每一个独立的子目录为一种风格的有关文件。

协议

在“协议”标签页上，可设定：

  • HTTP协议：

    • “提交者（referrer）”——某些http服务器只在访问其链接时才允许下载文件。选用此栏可让服务器知道你在访问它。
    “用户代理（User-Agent）”——某些http服务器只承认特定浏览器发出的请求。选用此栏可使NetAnts假作它是IE或Netscape。缺省时将报告给服务器此为NetAnts 1.0。
    这些都是对网络服务器有用的。如果你不知道它是什么，不要改变它。
  • FTP协议： 使用ASCII模式文件的内容除非依靠技术支援或网管员，这些设置你应当用默认值。

高级

在“高级”标签页上，可设定：

  • 启动NetAnts后立即开始全部任务下载。
  • 总是显示添加任务对话框。
  • 如果服务器不支持断点续传则停止下载。
  • 总以字节为单位显示。
  • 使用浏览器的cookies，在浏览器的cookies中寻找登录信息。
  • 每次自动存盘字节：下载多少字节后往磁盘存一次数据。考虑到系统可能发生故障的情况，建议把自动保存下载数据的值设置得尽可能的小。
  • 从服务器获取文件的日期和时间：把本地文件的日期设为服务器上文件日期和时间。
  • 创建 .NFO文件：.NFO文件是记录有关下载文件信息的文件。
  • 任务完成后从任务列表中删除任务项：在完成下载后删除任务项。如果你需要保持下载历史纪录、更新或再下载该文件，你应该不选此项。
  • 向winpopup发出信息通知：当任务完成时，发送信息通知。为此需要先运行winpopup程序。
  • 显示通知信息：当任务完成时，发送信息通知。
  • 使用声音：在添加任务、任务完成和发生错误时用声音发出通知。
  • 下载完成后挂断。
  • 下载完成后退出NetAnts。
  • 下载完成后关机。
  • 每天备份下载数据库。


na_8-1.htm

 下载单个文件

下载单个文件时，往NetAnts添加任务有5种方法：

  • 在浏览器中点击。可使用点击获取这一功能。
  • 右击URL并选择“Download by NetAnts”来下载。
  • 拖曳URL到拖曳窗口中。拖曳窗口的使用见“这里”。
  • 在NetAnts中直接使用“添加任务”菜单指令或工具条按钮。
  • 点击URL的同时按下Alt键。

    • 当你向NetAnts提交新任务时，“添加任务”对话框将出现。它有 “常规”、“连接”、“代理服务器”和“协议”四个标签页。 在“常规”标签页上，可设置URL、文件存放位置和文件名等项目。 其他 3个标签页上的选项，在设置“选项”部份已经进行了描述。但是，这些设置值只适用于该单个任务。

    加入任务时，点击存盘目录输入框旁边的第一个按钮，在下拉列表中可选择用“默认目录”还是用“上一次的目录”，若选“上一次的目录”则网络蚂蚁就会填入上一次使用的下载文件存放目录。

    任务完成或中止时，将弹出通知消息窗口。多个通知消息将显示在同一个窗口中。用户可以通过“选项”的“高级”标签下的“显示通知信息”来开关这个特性。


导入列表na_8-2.htm

导入和导出列表

  • 如果你下载很多文件，可以把这些文件的 URL编入一个文本文件，从文本文件中把这些URL导入。 点击“文件→导入列表...”菜单项或工具条按钮 [image] ，选择导入列表用的 URL 文件，则“添加任务”对话框将弹出。可以选择下载的文件、改变保存这些文件的目录。
    该列表文件应该是纯文本文件，并且每行一个URL。
  • 导出URL列表:选择多个任务之后，按鼠标右键，选择Export List，然后输入导出列表存放的文件名。


系列na_8-3.htm

 生成系列URL

有时需要下载许多文件，它们的文件名有顺序或是有规律的。例如：

http://www.foo.com/bar06a.htm
http://www.foo.com/bar07a.htm
http://www.foo.com/bar08a.htm
http://www.foo.com/bar09a.htm
http://www.foo.com/bar10a.htm
http://www.foo.com/bar11a.htm
http://www.foo.com/bar12a.htm

NetAnts对这类URL提供了简化的添加任务方法。
点击工具条按钮 [image] 或“文件→添加成批任务”菜单项，弹出“添加成批任务”对话框。它有2个标签页。

第一个标签页是“生成系列”。在上述例子中，要在URL项的左面空白框中输入：http://www.foo.com/bar。右面空白框中输入“a.htm”，其范围为6到12，数字位数为2。
注意：数字位数没有0位数，所以位数不能为“0”。如果系列URL中数字位数少于要求的位数，应选用“是否添加零”以在前面赋加上一个“0”。你也可以使用大写字母和小写字母来生成系列URL。

第二个标签页是“存盘选项”，可选择文件存盘的目录。

以上二个标签页填完并点击“产生系列”即刻产生系列URL。


 从网页获取URL

另一个导入URL列表的方法是从网页获取。

从在线的网页上导入URL列表

在网页上任意位置右击，选“Download all by NetAnts”。NetAnts 将从网页上寻找所有的URL，并显示在“添加任务”对话框的“选择文件”标签页中，以便选择要求的文件。 按“选择”按钮可以加上当前所选择的文件，按“不选”可以取消当前所选择的文件，按“进一步选择”可以通过主机地址和后缀名来选择文件。

从本地HTML文件导入URL

点击工具条按钮 [image] 或“文件→处理网页...”菜单项。在弹出的 windows的“打开”对话框中选定计算机上已有的HTML文件。象“从在线的网页上导入URL列表”一样选择要下载的文件类型。


系列na_8-3.htm

 导入未下载完的文件

在File菜单下面选择Import Broken Download，然后选择下载了一部分的本地文件。在添加任务 对话框中，输入原先的下载地址。网络蚂蚁就会帮你完成剩下的下载工作。


na_8-5.htm

与浏览器完美整合

NetAnts能与Internet Explorer，Netscape Navigator和NetCaptor等浏览器进行很好的整合:

  • NetAnts安装后被加到IE的“工具”菜单项中。
  • 在IE中选择文本并把它拖到拖曳窗口中，NetAnts将处理包含在文本范围中的URL。
  • 在浏览器中点击URL将根据文件类型（缺省类型为EXE和ZIP）来获取文件。
  • 点击URL的同时按下Ctrl键可阻止处理此URL。
  • 点击URL的同时按下Alt键则强制进行处理（对未定义类型的文件也处理）。


na_8-6.htm

 代理服务器与安全问题

使用代理服务器

NetAnts支持进行多个代理服务器的配置：

  • 按Add可以加入新的代理服务器项。在Name中填入这个代理服务器的名称，Address中填入代理服务器的地址，Port中填入端口号。然后选择代理服务器的类型。
  • No cache选中的话，将告诉代理服务器不使用缓存。
  • PASV mode选中的话，FTP下载时将采用PASV模式。
  • 如果该代理服务器需要认证的话，可以选中Authorization，再填写用户名和口令。
  • 按OK加入该代理服务器项。按Delete可以删除代理服务器项。按Edit可以重新编辑代理服务器项。
  • 选中一个代理服务器项后，如果选择下面的Default for HTTP或Default for FTP的话，该代理服务器项将成为对应协议任务下载时候的缺省代理服务器
  • 加入新的任务或者编辑任务属性的时候，Proxy的配置将大大方便，只需要在已经加入的代理服务器项中选择即可。
  • 支持SOCKS4和SOCKS5代理服务器,在支持的代理服务器类型中加入了SOCKS4和SOCKS5协议。
  • 选用“选项\设置”菜单项的“代理服务器”标签页中“对全部任务用缺省代理服务器”，所有任务都将按缺省的代理服务器配置。

设置用户名／口令

在“添加任务”对话框中，用手工输入用户名和口令，NetAnts 提供了自动登录的方法。如果经常访问一些需要认证用户的站点，可在URL或部分URL设置用户名和口令（称为掩码）。 例如，以johndoe和john123登记在微软公司站点，可在“安全” 标签页上输入“ftp://ftp.microsoft.com/*”。

注：输入的口令用“*”来显示。这就保证了你口令的保密性。


na_8-7.htm

 数据流控制

因为 NetAnts总是渴望占用较大的带宽，浏览器及其它网络程序也象NetAnts那样渴望占用较大的带宽。为了防止相互阻塞，NetAnts引入 了数据流控制的概念。

NetAnts中数据流控制有三种模式。

  • 不限制：不控制数据流。NetAnts可使用它需要的带宽。
  • 手工控制：用户通过在状态条上使用滑动杆（主窗口右下部）控制分配给NetAnts的带宽。
  • 自动控制：NetAnts 监视对外连接的活动，并且把相当数量的带 宽空出给每个新的连接。

    • 总带宽和分配给其它连接的带宽，在“选项”对话框中“连接”标签页上确定。


 虚拟文件夹

为了便于管理下载任务和显示、查看所有的已下载和未下载的任务的状况，NetAnts在主窗口中设有虚拟文件夹。NetAnts主窗口左边是“虚拟文件夹”的树形结构。虚拟文件夹分为任务状态和下载历史两个部分。

任务状态

在NetAnts中，任务状态定义如下:
  • 正常：未激活的任务。
  • 运行：正运行的任务。
  • 排队：待进行的任务。如果用户要NetAnts下载很多文件，把超过了规定的“最大下载任务数”的放在这里。每当完成一个文件下载时，排在队列最前面的即开始下载。
  • 错误：失败的任务。最普通的错误是：
    404被禁止；
    403找不到文件；
    文件的大小不可知或达到了最大错误数。
  • 已下载完：下载完的任务列在这里

    • 注：如果需要在列表中查看全部任务，点击虚拟文件夹的树形结构的根。右击任务列表窗口里的任务项，将弹出菜单，可执行该菜单中的命令项。 在任务列表窗口中选定一个任务项时，这个任务的详细情况将在“任务状况”窗口中显示。

下载任务的历史纪录

在NetAnts中，下载任务的历史纪录如下：

  • NetAnts能把下载任务按日期分类。
    目前，分为四种类型：昨天、 今日、上星期和一星期以前。
    用这些历史纪录，用户能更好的管理从网上下载的文件。


na_9-4.htm

 下载文件的管理

目前，NetAnts不能称作下载管理软件。还缺乏下载管理软件必须有的许多功能。 不过，他已经有了非常有用的功能。那就是根据文件扩展名对下载文件自动分类。 此功能在“选项 ”对话框中“存贮”标签页上设定。

例如，要把所有*.ZIP文件放在 C:\myfiles中，在“存贮”标签页中，类别（category）设定为“Archives”、 扩展名（Suffixes） 设定为“ZIP”、目录（Directory）设定为“c:\myfiles”。

设置完成后，NetAnts将自动按分类进行处理。当把URL拖到拖曳窗口中，可在弹出的菜单中选择存放文件的目录。这就可代替了原先设定的存放目录。

下载数据库备份：网络蚂蚁将自动备份最近三天的下载数据库，文件名为netants_bk1.job，netants_bk2.job和netants_bk3.job。一旦netants.job发生损坏的话，可以用这些备份文件来取代netants.job。


na_9-4.htm

 修复下载损坏的zip文件

下载完毕后，文件可能发生损坏而无法打开。这时，可以利用网络蚂蚁所独有的修复损坏zip文件功能进行修复。操作过程如下：选中下载完成的任务，点鼠标右键，选择“Fix Corrupt Zip"， 网络蚂蚁就会检查这个zip文件的CRC校验并标出损坏区域。检查结束后，再重新启动任务，让网络蚂蚁重新下载损坏区域即可。


na_9-4.htm

 Shell菜单整合

对于下载完毕的任务，右键点击，在菜单上选择Shell子菜单，将出现与下载下来的文件有关的所有资源管理器操作命令，用户可以直接选择，不需要切换到资源管理器中再进行操作。


na_9-4.htm

 常用下载地址书签

用户可以把常用的下载地址保存在书签中。在Tool菜单下面选择NetAnts Bookmark，在对话框中 可以加入新的下载地址，编辑以及删除现有的下载地址。选择Download则使用该地址来创建新任务。


na_10-1.htm

 标准匹配性

NetAnts是以HTTP和FTP协议的“继续运行”（RESUME）功能为基础的。如果你对技术性的细节有兴趣，请读RFCs:

  • RFC2626:超文本传送协议1.1
  • RFC959:文件传送协议

为了在网上找到RFCs，在任何主要的搜索引擎的搜索框中输入 RFC即可搜索到。


na_10-2.htm

第三方开发者的应用编程接口（API）

  • 对网络管理人员

    可以通过服务器端的控制标记来告诉网络蚂蚁如何来访问您的站点。以保护站点免受太多连接而阻塞。 为了限制单用户同时产生的连接数，对HTTP服务器：可以在应答信息中增加特定的头信息。对FTP服务器：可以在每个用户正确登录之后的welcome信息中增加特定行。语法为：

    {param1=value1;param2=value2;...}

    目前网络蚂蚁可以处理的参数包括：

    Param = MaxConnection

    Value = 1-5

    这个值指定了网络蚂蚁对于本站点的下载任务最多可用的连接数目。

  • 对软件开发人员

    可以使自己开发的应用程序通过 DDE 或 COM接口来控制网络蚂蚁。
    VC++和VB例子可从作者网点得到。

    Addon sample code in Visual Basic

    • Addon sample code in Visual C++


na_11.htm

提示与技巧

了解 NetAnts里的掩码

在NetAnts中的掩码非常灵活，而且方便。它用于许多功能，如URL自动登录和添加任务时使用文件名掩码。
在NetAnts中有２类掩码：
通配符掩码；
惯用符（regex）掩码。

在通配符掩码中可用“*”来表示串。用“？”表示单个字符。
例如，如果访问微软网站时需要自动登录注册，则掩码应该是 “*.microsoft.com/*”
请注意，如果你把掩码设为“http://www.microsoft.com”，则将不能登录到“http://www.microsoft.com/topsecret/”。

惯用符（regex）掩码用来表达常用符号。

避免屏幕和背景闪烁

为了避免在启动时屏幕闪烁，在注册表主键 HKEY_CURRENT_USER\software\NetAnts\Layout 下面加一个键值“NOSplash”并赋值为“1”。
为了避免窗口背景闪烁，在注册表主键 HKEY_CURRENT_USER\software\NetAnts\Layout 下面加一个键值“NOWindowBK”并赋值为“1”。

不按扩展名分类

NetAnts的自动分类是按文件扩展名进行的。有时，需要按下载文件名逻辑分类。例如，“Games”和“Utilities”，这些文件都可以是EXE或ZIP形式。

这里的工作是定义种类“Games”，并且把扩展名设为空白。现在每当往拖曳窗口拖曳URL时，对拖曳的URL将有一个加的存放目的地“Games”。
注意：这仅在使用拖曳窗口时起作用，对用点击获取和剪贴板监 视将不起作用。


问：启动NetAnts时，出错信息提示需要新的“COMCTR32”。

答：你需要微软公司新版本的COMCTR32.DLL。请在这里下载。

问：我已经设置蚂蚁数为５，为什么仅仅只有一个蚂蚁工作？

答：若远程服务器不支持断点续传，则只能有一个蚂蚁工作。

问：如何报告NetAnts的Bug？

答：若遇到Bug，请给support@netants.com 写信告知. 在邮件中请写明:
  • 你尝试下载文件的URL；
  • 你使用的操作系统；
  • 在日志窗口中的信息；
  • 你的NetAnts的版本号；
  • 出现非法操作时寄存器的内容；
  • 关于错误的描述，它是否可再现？如何再现。

问：为什么对每个任务不能使用更多的蚂蚁数？

答：最适当的蚂蚁数要适应网络和服务器的状态。当蚂蚁数目增时，下载速度并不能无限制的提高。蚂蚁太多是造成网络阻塞的因，并且影响其它的用户。

问：在任务列表窗口中“错误”列中显示出了错误数，是否意味 着下载文件已被破坏？

答：在这里所显示的错误是网络连接问题。通常，它不影响下载的文件。

问：为什么任务完成95%时下载变得非常慢或停下来？

答：接近完成时，多数情况下只有一个或二个蚂蚁在工作，并且它们可以遇到拥挤和超时。

问：为什么当我输入新的任务时，NetAnts报告坏的URL?

答：在NetAnts中要求完整的URL才能使用。其正确的格式如下：
“协议：//网站：接口／目录／文件.扩展名”
这里协议FTP或HTTP和接口通常被省略，大部分网站使用缺省值。
注意：你不能省略文件名部分。

问：下载文件时，报告“下载文件的大小未知”，拒绝运行。

答：NetAnts必须知道下载文件的大小。这一出错信息表示服务器不给出文件大小的信息。这将在以后的版本中改进。

问：如何能知道网站是否支持断点续传？

答：在任务列表窗口中每个运行的任务将出现一个小图标。如果你看到由红蓝绿组成的三色图标，说明这个站点支持断点续传。如果全是灰色的，则这个站点不支持断点续传。如果没有小图标，则是不能决定该站是否支持断点续传。另外，在主窗口下部的“任务状况”窗口“信息”栏下面“断点续传”(RESUME) 项中，若为“yes”即为该网站支持断点续传。

问：为什么NetAnts提示我将在10秒钟后关机？

答：因为你设置了在全部任务完成后自动关机。请从工具条或主菜单解除这一项的设置。

问：我希望NetAnts对列队等待的任务一个一个地下载。

答：在“选项”对话框中“连接”标签页上把“最大下载任务”的值设定为“1”，即可一个一个地下载。

问：拖曳窗口不见了。

答：使用工具条和主菜单中“显示／隐藏拖曳窗口”。

问：为什么总是和我下载的文件同时有.NFO文件？

答：NFO文件是下载文件的记录。包括：URL、本地文件名、下载时间和注解等。在“选项 ”对话框的“高级”标签页中可以控制是否对所有任务产生NFO文件。

问：NetAnts登录FTP网站的缺省用户名和口令是什么？

答：用户名是anonymous(匿名),口令是“whoami@unknown.net”。

问：在NetAnts工作时，我的浏览器应答得非常慢。

答：请用数据流控制功能来控制 NetAnts用来下载文件的带宽。

问：在添加任务时，添加任务对话框上协议标签页中的“提交者”(Referrer)一栏里填什么？

答：有的网站要求提供正确的“提交者”（Referrer）的域名，才 可下载文件。在这里要输入URL目标网站的域名。

问：为什么NetAnts不能登录到FTP网站？

答：为了改善NetAnts对FTP网站的登录性能，把注册表主键： HKEY_CURRENT_USER\software\NetAnts\configur 中
“DefaultPassword”的键值由原来的
“IfmnoOmRWEx0sNZoHq583hvMrFLMQfxs”改为“ ”（空）。
也可以把缺省口令设为您的电子邮件地址。将缺省口令恢复为原先的whoami@unknown.com
也可从作者网页上下载补丁文件 fix_defaultpasswordFTP.reg 来修改注册表。

问：怎样更改下载文件的存盘文件名？

答：点击 Rename右面的小图标，文件原名即显示在Rename 框内， 可在原名的基础上很方便的进行改名。


na_13.htm

 联系信息

NetAnts当前是按广告赞助软件发布的。然而，这是作者向你奉献的同类软件中高质量和代表目前发展最高水平的软件。

如果你需要帮助、 发现了错误（bug），或者有关于将来版本的想法，请你：

  • 访问NetAnts网站: www.netants.com
  • 给作者发信: support@netants.com
  • 订阅NetAnts的邮件列表: